スポンサーリンク

バージョンアップしたらjetpackが連携できず有効化できないエラー

投稿日:

本日の人気記事BEST10

所要時間目安: 約 3

jetpack連携できない

WordPress アップグレード 不具合 伝えたいこと 備忘録

本日、やいやいと思いWordPressのバージョンを4.5.1からそろそろバグや不具合などの情報も出きったのかなぁ…。なんて思いバージョンアップをしました。

そしたら、jetpackが連携できなくなってしまいました。

いろいろと検索してみると以前のWordPressのバージョンなどでもあったようで…。
また、wpblogにおいても4.6.1にしたところjetpackとの連携できなくなってしまいましたという質問(Q&A)サイトにありました。

他のブログなどの情報ですと、



スポンサーリンク

目次

jetpackを4.2.2にすると大丈夫みたいなことがありましたので、以下よりダウンロードしてFTPにてアップロードしてみたのですがダメでした(;´д`)トホホ…、。

それなら、
WordPress4.5.1で使用していたjetpack4.3.1なら大丈夫ではないかと思いましたが、やはりダメでした・・・・・・。

とりあえずjetpackの過去バージョンのダウンロード先以下になります。

https://downloads.wordpress.org/plugin/jetpack.4.2.2.zip

https://downloads.wordpress.org/plugin/jetpack.4.3.1.zip

しかも、

WordPress.comに登録済みの当ブログのURLとサイト名が消えてしまっていました。(><) 

なんでなの??

もうひとつのブログは残っていましたが(WordPressのバージョンアップはしていません。)

また海外からのIPアドレス制限はかけたままですがそちらは正常にjetpackが機能しています。

先日からサーバダウンのお知らせメールがjetpackから来まくっていましたので、

WordPressのバージョンアップしないとセキュリティ的に良くないのかなぁ。
なんて思い焦って?

(もいないのですけれどね。だってもう3ヶ月くらい経ってるもん。)
バージョンアップしたのが(;´д`)トホホ…)みたいない感じになってしまいました。

 

とりあえず、エラーログも残しておきたいと思います。

 

The Jetpack server was unable to communicate with your site [HTTP 403]. Ask your web host if they allow connections from WordPress.com. If you need further assistance, contact Jetpack Support: http://jetpack.com/support/

 

エラー詳細: The Jetpack server was unable to communicate with your site [HTTP 403]. Ask your web host if they allow connections from WordPress.com. If you need further assistance, contact Jetpack Support: http://jetpack.com/support/

お陰でデバックDebugやWindowsにおいてコマンドラインcURLなんかも覚えちゃったりもできました。
ある意味、ありがたいとでも言えるのでしょうか…。ポリポリ (・・*)ゞ。

何やら403エラーログなのでサイトにアクセスできません的な感じなので・・・・・・。

ちょっとだけ国外IP制限を両方(秘密ですが)外しておきました。

しばらくこのまま様子を見て連携できなければWordPressのダウングレードも考えてみたり…。

でも、
脆弱性の問題からすると最新バージョンの方が良いという葛藤…。o(´^`)o ウー

明日か数時間後には解決していますように…。†o(・・;) アーメン

 

ということで、解決方法ですが・・・・・・。

解決方法は、単にサーバーダウンが多かったのでサーバー管理会社がサーバー負荷軽減の為に、
一部海外からのIPアドレスのアクセスに制限をかけていたということでした。

障害情報を拝見したところ、当ブログのサーバーIPがw(゜ー゜;)wワオッ!!

だから、jetpackからサイトダウンしてますよぉ。
という通知メールが何通も届いていたのでした。

 

なんか何度も通知が来ていたりするとセキュリティー的にマズくなってきたのかな?

なんて勘ぐってしまいました。
おかげでパスワードも変更してしまいました。ポリポリ (・・*)ゞ。

まぁ、これはこれでイイコトとしましょう。

そして、サポートに連絡すると・・・・・・。

数時間以内に返信がきました。
障害により一部のアクセス制限を一時的にしているとのことでした。

しかし、問い合わせさせて頂いたお陰でアクセス制限を解除して頂き、
jetpackを有効化したところしっかりと連携ができました。

いろいろと調べて勉強にはなりましたが時間と体力が消耗しちゃいました。(汗)。

スポンサーリンク

その後は、このjetpackとの連携ができなかった時に旧バージョンのjetpackなどをFTPツールにてサーバーにアップロードしたものが、削除できなくなってしまいました。

そのことについては以下にまとめてありますので、是非読んでみてください。

サーバー上のファイルやフォルダが削除できなくなってしまった際にはお役に立つと思われますので…。

えーっ、(汗)。この度WordPressのバージョンアップ後にjetpackが連携できなくなってしまいまして…。 その詳細は次回にしますが、結果しっかりと連携できました。(#^

-WordPress, アップグレード, 不具合, 伝えたいこと, 備忘録

スポンサーリンク




この記事が良かったら
いいね!お願いします(#^.^#)

WordPressデビュー津々浦々の
最新情報をお届けします

言えないことはTwitterで!!



よろしかったらシェアよろしくお願いします。

Copyright© WordPressデビュー津々浦々 , 2017 AllRights Reserved Powered by AFFINGER4.